It is currently Fri Jan 24, 2020 12:21 pm

Reply to topic  [ 3 posts ] 
 Does Doom 3 work in planar mode? 
Author Message
One Eyed Hopeful

Joined: Thu May 03, 2007 4:02 pm
Posts: 17
Reply with quote
I just found (yet another I suppose) a glitch with the recent nvidia stereo drivers : doom 3 does not work in planar mode. It DOES go into stereo, and it works fine in analglyphic and shutter modes, as well as some of the weirder modes. Sharp 3d works, but not planar!

This is probably a very minor problem in the nvidia drivers : Neil, can you give me an email address where I can contact the stereo3d development team? T

Wed Jun 06, 2007 2:18 pm
Golden Eyed Wiseman! (or woman!)
User avatar

Joined: Wed May 16, 2007 11:30 am
Posts: 1387
Location: Europe
Reply with quote
I had problems with planar mode, too.
C&C3 had no mirrored mouse - it was at the same coordinates, even if there were totally different pictures.
CS1.6 didn't work correctly either. One of the screens had only one vision and the other one looked like it was rendered for shutterglasses.
With switched Setup and Stereo-Type at least CS workes great. Haven't tried C&C jet...

I think the support for the planar setup is lacking in general :(

Play Nations at WAR with this code to get 5.000$ as a Starterbonus:

AMD x2 4200+ 2gb Dualchannel
GF 7900gs for old CRT with Elsa Revelator SG's
currently 94.24 Forceware and 94.24 Stereo with XP sp2!

Wed Jun 06, 2007 2:35 pm
Profile WWW
One Eyed Hopeful

Joined: Thu May 03, 2007 4:02 pm
Posts: 17
Reply with quote
Post Hmm
CONFIRMED : ALL OpenGL games do NOT work in planar mode. Period, support is totally kaput. I need that email address or some kind of info, Neil, because this is something Nvidia can and should fix.

Luke, that game, as well as Prey and Doom 3, all use OpenGL rather than direct3d. I would guess nvidia's implementation of OpenGL in stereo is broken for planar mode somehow, in recent driver versions. I read some posts that 70ish series drivers would do planar ok. However, a LOT of things are fixed in the latest drivers, so I am not willing to revert.

Luke : I just checked. CnC3 : Tiberium wars DOES work in planar 3d. Quite well, I might add. You just have to add "StereoTextureEnable" = 1 ( a DWORD VALUE) to the cnc3game registry entry in the stereo3d drivers. Hit cntrl-F7 in game to add that item to the registry.

To fix your problem : put CS, that mod for half life, into direct3d mode! It'll probably work.

Wed Jun 06, 2007 4:28 pm
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by STSoftware.