3Dmigoto mouse cursor position troubles

Post Reply
User avatar
Innuendo1231
One Eyed Hopeful
Posts: 37
Joined: Mon Dec 12, 2011 2:01 pm

3Dmigoto mouse cursor position troubles

Post by Innuendo1231 »

Hello eveyrone.

I'm having mouse position troubles with 3Dmigoto's upscale function. I always have to use this feature because I have a 4K passive TV so rendering resolution (like 1080p) has to be upsacled to native.

So here's the scenario. This game's fix includes a mouse shader fix, here's the relevant parts (I guess) of the mouse.ini

Code: Select all

; Bind the back buffer as a render target. set_viewport ensures that the view
; port is the size of the buffer so the draw call will work:
o0 = set_viewport bb
; Back up IniParams we are about to use:
local $bak_x0 = x0
local $bak_y0 = y0
local $bak_z0 = z0
local $bak_w0 = w0
local $bak_x1 = x1
local $bak_y1 = y1
local $bak_z1 = z1
local $bak_w1 = w1
; Pass cursor position and visibility info to the shader:
x0 = cursor_window_x
y0 = cursor_window_y
z0 = cursor_hotspot_x
w0 = cursor_hotspot_y
z1 = cursor_showing
; Pass the size of the window to the shader:
x1 = window_width
y1 = window_height
The results are: The cursor remains within the screen area, but the effective position of the cursor is double the distance from the top left corner then where the cursor is seen.

If I change either:

x0 = cursor_window_x ----> x0 = cursor_screen_x
y0 = cursor_window_y ----> y0 = cursor_screen_y

or

x1 = window_width ----> x1 = res_width
y1 = window_height ----> y1 = res_height

or both

the results are: The cursor's effective position and visible position are matching, but the cursror can go out of the screen area. Quite annoying having to bring it back from the void every time a dialogue option comes up.

I was only mocking around with a trial & error approach, so I suspect someone who actually knows the wheres n' the whys of all this code should know what the solution is. I'd be greatful for it. Also is this the proper platform for 3Dmigoto support?...

3DNovice
Certif-Eyed!
Posts: 569
Joined: Thu Mar 29, 2012 4:49 pm

Re: 3Dmigoto mouse cursor position troubles

Post by 3DNovice »

Long ago, I used a program called cursor lock, no idea if it still works, but perhaps there's a similar program.
Display Fusion might offer it

http://www.snakebytestudios.com/project ... rsor-lock/

3DNovice
Certif-Eyed!
Posts: 569
Joined: Thu Mar 29, 2012 4:49 pm

Re: 3Dmigoto mouse cursor position troubles

Post by 3DNovice »

I reread your post, if you go to "Device" in the d3dx.ini you can try setting (always force fullscreen) and/or height/width

[Device]

; (0) - disable upscaling
; (1) - enable upscaling and allows the game to disable and enable fullscreen mode
; (2) - enable upscaling and don't allow the game to switch fullscreen mode
; (always force fullscreen). Try this if you get issues with the mouse cursor.
; Note if you enable upscaling please do not forget to:
; 1) Uncomment "run = CustomShaderUpscale" in the [Present] section,
; otherwise you will see only a black window (with game sound).
; 2) Set a custom resolution here for width and height that the game will see.
; 3) Uncomment upscale_mode here.
upscaling = 0

; Force override the screen resolution.
; If upscaling is on, the resizing functionality is disabled.
; If upscaling is on, then you MUST specify the resolution the game will be upscaled to.
; To achieve the best visual result use the native resolution of your tv or monitor.
;width=1280
;height=720

; upscale_mode = 0: 3Dmigoto creates a texture and pushes it as the back buffer for the game.
; Seems to work with only few games but everything seems to run a bit smoother.
; upscale_mode = 1: 3Dmigoto creates a second swap chain and pushes the game to use it.
; Seems to work with most games. dont forget to activate upscaling shader in [present] section
;upscale_mode = 1

User avatar
Innuendo1231
One Eyed Hopeful
Posts: 37
Joined: Mon Dec 12, 2011 2:01 pm

Re: 3Dmigoto mouse cursor position troubles

Post by Innuendo1231 »

Oh yes, I forgot to mention that I tried that, but the game won't start that way.

3DNovice
Certif-Eyed!
Posts: 569
Joined: Thu Mar 29, 2012 4:49 pm

Re: 3Dmigoto mouse cursor position troubles

Post by 3DNovice »

Maybe the problem is the game is rendering at 4096x2160, which is the "native" 4K resolution on many displays.
Try using CRU to remove this resolution from the EDID

You can also open NVCP and try the settings in "Adjust desktop size and position"
Like switching between scaling on the GPU and Display

Or what if you right click the game's exe and use the "Change high DPI settings" or "Disable Fullscreen Optimizations"

User avatar
Innuendo1231
One Eyed Hopeful
Posts: 37
Joined: Mon Dec 12, 2011 2:01 pm

Re: 3Dmigoto mouse cursor position troubles

Post by Innuendo1231 »

3DNovice wrote: Fri Apr 02, 2021 11:02 am Maybe the problem is the game is rendering at 4096x2160, which is the "native" 4K resolution on many displays.
Try using CRU to remove this resolution from the EDID

You can also open NVCP and try the settings in "Adjust desktop size and position"
Like switching between scaling on the GPU and Display

Or what if you right click the game's exe and use the "Change high DPI settings" or "Disable Fullscreen Optimizations"
I'm afraid you don't understand. This is a passive 4k display. The output resolution must be 4k. But as you may guess, rendereng 4k stereo is too much, even for an rtx 2080. The only option is to use the scaling feature of 3Dmigoto, which I'm really greatful for.
In other words, yes, the scaling introduces the problem but it is necesary. I beleive the solution would be to adjust the mouse shaderfix to work with it, I just don't know how.

I tried adding using some formula, like cursor_window_x*2 , but it didn't do anything. Maybe it sould be entered a different way, i was hoping the creators of the mouse shader might know.

3DNovice
Certif-Eyed!
Posts: 569
Joined: Thu Mar 29, 2012 4:49 pm

Re: 3Dmigoto mouse cursor position troubles

Post by 3DNovice »

Innuendo1231 wrote: Sat Mar 20, 2021 4:06 pm If I change either:
x0 = cursor_window_x ----> x0 = cursor_screen_x
y0 = cursor_window_y ----> y0 = cursor_screen_y

or

x1 = window_width ----> x1 = res_width
y1 = window_height ----> y1 = res_height
Doing this is changing the bounding box of the cursor from 3840x2160 to 2160x3840, so no wonder why it is going off screen.

Try this, go to the game's .exe file, select properties, go to the Compatibility tab and enable "Disable display scaling on high DPI settings" W8.1 or "Override high DPI scaling behavior" W10.
.


https://docs.microsoft.com/en-us/troubl ... tly-scaled
"Windows 8.1/10 supports bitmap scaling of desktop application content for applications that don't natively support high-DPI displays. It also scales mouse, pen, and touch input that is sent to those applications. Scaling both input and output guarantees a consistent experience for the application user.

However, there are two scenarios in which scaling can be mismatched:

Games that run in full-screen mode and bypass the output scaling of Windows (only input is scaled)
Games that use "raw mouse input" in windowed mode and bypass the input scaling of Windows (only output is scaled)

Most Windows desktop applications don't use full-screen mode or raw input. However, games frequently use one or both configurations. Windows detects many full-screen games and exempts them from both input and output high-DPI scaling on successive starts. But this detection fails in some games and upgrade scenarios. In these cases, you may experience mouse input that is either consistently larger or consistently smaller than what is reflected on the screen. The effect can be seen either in the position of the pointer or the location at which you can interact with on-screen content."
Last edited by 3DNovice on Fri Apr 09, 2021 8:05 am, edited 1 time in total.

3DNovice
Certif-Eyed!
Posts: 569
Joined: Thu Mar 29, 2012 4:49 pm

Re: 3Dmigoto mouse cursor position troubles

Post by 3DNovice »

...double post
Last edited by 3DNovice on Fri Apr 09, 2021 8:05 am, edited 1 time in total.

User avatar
Innuendo1231
One Eyed Hopeful
Posts: 37
Joined: Mon Dec 12, 2011 2:01 pm

Re: 3Dmigoto mouse cursor position troubles

Post by Innuendo1231 »

Sorry, I already disabled the DPI scaling and disabled full screen optimizations.

3DNovice
Certif-Eyed!
Posts: 569
Joined: Thu Mar 29, 2012 4:49 pm

Re: 3Dmigoto mouse cursor position troubles

Post by 3DNovice »

Try this for W10

hit the widows key and s

type in mouse settings

in the upper left corner select "advanced mouse options"

in the mouse properties window, select "Pointer Options"

check the box for "Enhance pointer position" and then also change the pointer speed to a faster setting

If you are using a gaming mouse with it's own software, look there for similar settings and try a higher DPI setting.
Typically, these programs will let you set set up a profile for gaming and desktop use or let you bind DPI settings to a mouse button to easily switch as needed.

3DNovice
Certif-Eyed!
Posts: 569
Joined: Thu Mar 29, 2012 4:49 pm

Re: 3Dmigoto mouse cursor position troubles

Post by 3DNovice »

So did you find anything that worked?

Post Reply

Return to “Nvidia 3D Vision Fixes, Solutions and Troubleshooting”