Page 1 of 1

Outlast won't start

Posted: Fri May 08, 2015 6:35 am
by Slash
Hey guys,

first off i really appreciate your awesome work with this drivers.

So now let's get to my problem. ;)

First i've tried Bioshock and it works flawlessly.
After that i've wanted to try out Outlast.
So i did what i was told to do in the manual of vireio.
I've injected the DLL files to the outlast folder but after that i can't start the game anymore. I always get the error code 0x000007b.
If i remove the DLL files the game starts fine again.

I really don't know what to do anymore :(

Can you help me please as i really want to play outlast with the oculus :)

Re: Outlast won't start

Posted: Sat May 09, 2015 9:49 am
by DrBeef
That's the error that usually occurs when you use 64bit dlls with a 32bit application or vice versa.

Outlast is only supported for 64 bit. If you are trying to play 32 bit version I'm afraid it won't work. If you manually copied the 32bit dlls to the game folder then remove them and use the symlink installer instead.

And when it does start working... keep some spare underwear to hand!

Re: Outlast won't start

Posted: Sat May 09, 2015 10:18 am
by Slash
The installer automatically detects the 64 bit version of the game and injects the files to the 64 bit folder. But i can't start the 64 bit version of Outlast. It crashes everytime like i've described in my first post. :(

Edit: It seems like the symlink installer is copying the wrong file. It copies the d3d9.dll instead of the d3d9_64.dll. The other files are the 64 bit versions.
Could this be the error? And if yes, what can i do? I've tried to copy the d3d9_64.dll manually to the folder. After that the game starts fine but perception just won't hook in. Here is a screenshot of the folder.

Edit 2: Well i see. The d3d9_64.dll symlink is just renamed to d3d9.dll
So i guess there is a problem with the 64 bit DLL file. If i copy the 64 bit dll to the Outlast folder i have the 0xc000007b error everytime. If i remove the d3d9.dll (64 bit everything is fine). I just don't know what to do anymore. I wanna play this game so badly with my new rift :(

Re: Outlast won't start

Posted: Sun May 10, 2015 3:19 pm
by DrBeef
Just had a thought.. download and install the Microsoft Visual Studio 2012 re distributable 64 bit, you should be able to download it from here.. I suspect that is what the problem is: ... x?id=30679

Re: Outlast won't start

Posted: Sun May 10, 2015 5:44 pm
by Slash
Same error after installing the redistributable. I just don't know what i'm doing wrong. Without the d3d9.dll the game runs fine. As soon as the dll file is in the outlast folder the game stops working and gives me the error right at the start.
I even tried redownloading the game 3 times and deleting everything related to it. But nothing seems to help :/

Re: Outlast won't start

Posted: Mon May 11, 2015 4:39 am
by DrBeef
Out of interest, you say "new rift".. have you been into the Oculus configuration utility and created a default profile? you absolutely have to do this as apart from it not having the correct IPD otherwise, there's a known crash in Vireio at the moment if there's no default configuration.

If you have done this already though.. then I am getting to the end of possible suggestions.. I will think further though, that error is usually the result of the OS considering a DLL to be bad (i.e. wrong bit length, or simply corrupt). I doubt the game itself is the issue, and no-one else appears to have this problem, so it might be some other dependency.

Have you tried any other games successfully?

Re: Outlast won't start

Posted: Mon May 11, 2015 4:59 am
by Slash
Yes, i've tried bioshock 1 and 2 and they are working so well. I really love to play them. And yes, of course i've created a oculus profile ;)
Portal 1 works too very well except the fact that the portal gun looks like it's big as a car :D

Re: Outlast won't start

Posted: Wed May 13, 2015 4:09 am
by DrBeef
Have you tried any of the other 64bit games?, The Vanishing of Ethan Carter is very good and would be interesting to see if it suffers from the same issue, bit of a waste if it does though. Similarly Chivalry Medieval Warfare has 64bit support too. WOuld be interesting to know if this issue is limited to Outlast or all 64 bit games on your system.

Must admit I am currently out of ideas. Sorry..

Re: Outlast won't start

Posted: Wed May 13, 2015 6:53 am
by Slash
Don't worry. :)

Yes, Ethan Carter works very well with the 64 bit version. It really seems a problem related to Outlast. I'm running out of ideas too ;D

Re: Outlast won't start

Posted: Mon Jun 08, 2015 5:04 am
by baggyg
Have you tried manually copying the 64 bit versions of the DLLs to the correct 64 bit folder?

It wasn't clear whether you had tried this....