Meant to be Seen
https://www.mtbs3d.com/phpbb/

Vireio worked for a few hours then stopped?
https://www.mtbs3d.com/phpbb/viewtopic.php?f=141&t=19008
Page 1 of 1

Author:  SkyMage420 [ Fri Dec 27, 2013 4:04 pm ]
Post subject:  Vireio worked for a few hours then stopped?

I wish I could be more specific about how I broke this, but I'll try my best.

I downloaded Vireio perception on Dec 5th, I don't see a version on it. The filename is "Perception_D3D_proxy.zip."

I was able to get my game, There.com, running by placing the DLL files form the Bin folder into the game's executable path:
d3d9.dl
hijackdll.dll
libfreespace.dll

The game worked immediately, but only with the perception.exe application running prior to launch. I rebooted, relaunched the game many times, all was well. I needed to adjust my field of view, so I ended up downloading the latest version, perception2_0_0_2.zip. I closed my old version , launched the new one, and copied the three replacement DLL files into the games directory, along with the new VRboost.dll. My game immediately stopped working in 3d, and began launching normally.

I've tried copying the old version of the perception files back to the game's folder and running the old perception.exe, no dice. I reinstalled the game from scratch and tried applying each version of Perception to it, no dice. I've tried monitoring my game with Process Monitor, and I can see that it is in fact reading the perception files, from perception's directory (not its own.) I can also see it looking in perception's folder for files that aren't supposed to be there, like HID.DLL.

For version 2_0_0_2, placing the d3d9.dll in the games folder, OR having the perception.exe application running causes my game to crash instantly on launch, so I'm sort of assuming that it's not compatible and trying to get the older version working again.

When I place the older version of d3d9.dll in the game's folder, the game crashes. When I don't, Perception doesn't seem to do anything. Any suggestions?

Author:  Neil [ Fri Dec 27, 2013 5:55 pm ]
Post subject:  Re: Vireio worked for a few hours then stopped?

I need more information:

1. Game
2. Where the game is from (e.g. Steam?).
3. Hardware and display specs

Regards,
Neil

Author:  SkyMage420 [ Sat Dec 28, 2013 6:52 pm ]
Post subject:  Re: Vireio worked for a few hours then stopped?

I got There.com (an online game commonly called "There") working with v2_0_0_2, by placing the DLL files in the games directory. If I have perception.exe running, the game crashes instantly. If I configure the stereo and tracker modes via the drop downs then close perception.exe and launch the game, it works great.

I'm not able to access the onscreen menu with CTRL+T, so I haven't been able to make some needed adjustments yet. In the previous version, I was able to disable 3d with Num0, and that was extremely useful...

I'm learning cheat engine now and examining in the game's memory for camera rotations, but so far all I've found are a pair of x, y, z positions...one set to locate the camera, and one to aim it? I'm not really sure how to use these. To make a VRBoost profile, do I absolutely have to find rotational floats?

Author:  EisernSchild [ Sun Dec 29, 2013 8:08 am ]
Post subject:  Re: Vireio worked for a few hours then stopped?

Hi SkyMage420 !

I actually download There and should be able to take a look at this game within the next days. This definately would make sense to play in VR !

We still have crashing issues with the driver, the more games we can debug the more stable the driver will get.

Yes, to make a VRBoost profile you definately need to find changeable rotational floats (or integers.... Unreal rotator angles are integers for instance). I will send you a PM whenever i started this game to match up about the VRBoost profile.

If you have any VRBoost related questions, please start a thread in the new VRBoost section of the forums (or send me a PM).

Regards, Denis

Author:  SkyMage420 [ Sun Dec 29, 2013 3:00 pm ]
Post subject:  Re: Vireio worked for a few hours then stopped?

Denis,

That's wonderful news! i'm so excited that you're willing to help! And, I know others in our community will be stoked as well. Our game (there.com) became pay to play a few years ago to support its high hosting costs and remain ad free. I'd be delighted to sponsor you, just supply me with your avatar name (or desired avatar name and email address) so i can apply some time for you :) I'm not actually sure how to do that, but I'll figure it out. It's a new feature lol.

Cheers!

-SkyMage

Page 1 of 1 All times are UTC - 6 hours
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/