It is currently Thu Aug 22, 2019 7:52 am



Reply to topic  [ 3 posts ] 
 WiiMote Plus TR not working 
Author Message
One Eyed Hopeful

Joined: Fri Dec 23, 2011 9:55 pm
Posts: 7
Reply with quote
Hi! I wrote in a while back, asking if the Wiimote button driver supported the RVL-CNT-01-TR Wiimote Plusses, and having tried the latest release, the answer seems to be no :(

I'm using the Toshiba bluetooth stack on Windows 7 x64, the device is registered and connected--it works fine in Dolphin--And GlovePIE no longer works on my system, so I cannot test it there--unfortunately, FreePIE gives me the error "No Wiimotes found in HID device list."

Is there anything I can do to help get this supported?

EDIT: The script I'm attempting to use is the wiimote[0] half of the dual wiimote script from the example scripts thread.

Code:
MOUSE_SPEED = 3;

-- Right Wiimote

-- mouse cursor/ aiming
if (wiimote[0]:getRight()) then
   mouse.DeltaX = MOUSE_SPEED;
elseif (wiimote[0]:Left()) then
   mouse.DeltaX = -MOUSE_SPEED;
end

if (wiimote[0]:getUp()) then
   mouse.DeltaY = -MOUSE_SPEED;
elseif (wiimote[0]:getDown()) then
   mouse.DeltaY = MOUSE_SPEED;
end

-- right attack
mouse.LeftButton = wiimote[0]:getB();

-- jump
keyboard:setKey(Key.Space, wiimote[0]:getA());

-- crouch/sneak toggle
keyboard:setKey(Key.LeftControl, wiimote[0]:getMinus());

-- run toggle
keyboard:setKey(Key.CapsLock, wiimote[0]:getPlus());

-- inventory
keyboard:setKey(Key.Tab, wiimote[0]:getHome());

-- Enter
keyboard:setKey(Key.Return, wiimote[0]:getOne());

-- Esc
keyboard:setKey(Key.Escape, wiimote[0]:getTwo());


Wed Aug 01, 2012 7:12 am
Profile
Petrif-Eyed
User avatar

Joined: Sat Sep 17, 2011 9:23 pm
Posts: 2220
Location: Menlo Park, CA
Reply with quote
I'm in Dallas right now, but I will check my Wiimotes when I get back home in a few days to see which batch they are from. I did buy them less than a year ago. They are the modern type that have the Wiimote and Plus integrated into a single device.

I have only tested with the standard Windows 7 bluetooth stack. At some point I am going to push the most recent wiimotelib beta into FreePIE so I can access the gyro. Maybe this might help with incompatibility issues.

Why is GlovePIE not working on your system?


Wed Aug 01, 2012 9:16 am
Profile
One Eyed Hopeful

Joined: Fri Dec 23, 2011 9:55 pm
Posts: 7
Reply with quote
GLovePIE's got the weird problem that, on startup, it will give a dialog that says "Invalid Pointer Operation"--after which, the UI will show up, and it can load and save scripts, but running them does nothing. That happens on both win7 x64 and winXP 32, even fresh after an OS reinstall.


Wed Aug 01, 2012 12:14 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by STSoftware.