It is currently Tue Jan 28, 2020 11:57 am



Reply to topic  [ 81 posts ]  Go to page Previous  1, 2, 3  Next
 Trine 4 
Author Message
Two Eyed Hopeful

Joined: Mon Sep 16, 2019 8:29 am
Posts: 76
Reply with quote
Thanks DJ-RK!

The auto-convergence works really well as-is - so much so that I really don't notice it. The only exception at this point would be the transition in cut scenes... seems slow to me.

I still get artifacting and lighting issues in some scenes (mostly outdoors, but some interior as well)... mentioning in case you aren't seeing them in your setup or if anyone else might be having the same experience.


You do not have the required permissions to view the files attached to this post.


Thu Oct 24, 2019 11:56 pm
Profile
One Eyed Hopeful

Joined: Fri Oct 04, 2019 7:40 am
Posts: 4
Reply with quote
Thanks DJ-RK for the great fix. Just send a donation :)


Fri Oct 25, 2019 1:02 pm
Profile
One Eyed Hopeful

Joined: Mon Sep 16, 2019 6:47 am
Posts: 8
Reply with quote
hi DJ
I tried your fix but im also getting weird square artifacts and some one eye issues - for example the fire in the beginning shows only in one eye.
it happens to me on my lg oled but also on my asus screen
thanks


Fri Oct 25, 2019 2:31 pm
Profile
One Eyed Hopeful

Joined: Wed Oct 23, 2019 2:45 pm
Posts: 2
Reply with quote
Thanks DJ-RK, it is working fine for me. As others i am getting few weird artifacts time to time, but it is already a good achievement.


Fri Oct 25, 2019 3:30 pm
Profile
Cross Eyed!

Joined: Thu Sep 19, 2019 8:13 pm
Posts: 164
Reply with quote
Ok, so I think I've figured out why (up until now) I haven't been seeing the same thing as everyone else. Up until today I've had 2 GPU's and SLI enabled. I just pulled out one of my cards (going to sell it. Sick of it sitting around not being used at all, since SLI is effectively dead), and it finally occurred to me how usually these types of issues are related to SLI setups (although it's usually the other way around: people with SLI have issues and single GPU's are fine) so I fired up the game, and low and behold I was presented with fire appearing in one eye only, whereas before it was perfectly fine.

So yeah, that's a HUGE step towards me fixing this stuff is that I'm able to see the same thing others are... or, y'know, you could all just go out and buy a 2nd GPU instead and save me the hassle! lol j/k.


Fri Oct 25, 2019 7:19 pm
Profile
Two Eyed Hopeful
User avatar

Joined: Mon Sep 16, 2019 10:01 am
Posts: 52
Reply with quote
DJ-RK wrote:
Ok, so I think I've figured out why (up until now) I haven't been seeing the same thing as everyone else. Up until today I've had 2 GPU's and SLI enabled. I just pulled out one of my cards (going to sell it. Sick of it sitting around not being used at all, since SLI is effectively dead), and it finally occurred to me how usually these types of issues are related to SLI setups (although it's usually the other way around: people with SLI have issues and single GPU's are fine) so I fired up the game, and low and behold I was presented with fire appearing in one eye only, whereas before it was perfectly fine.

So yeah, that's a HUGE step towards me fixing this stuff is that I'm able to see the same thing others are... or, y'know, you could all just go out and buy a 2nd GPU instead and save me the hassle! lol j/k.


I thought I was the only one having problems with one eye, I had lost all hope of being able to play it in 3D with my daughter.
give me hope thanks
instead of buying a second gpu I will send donation :)

Pensavo di essere il solo avere problemi con un occhio solo, avevo perso ogni speranza di poterlo giocarlo in 3D con mia figlia.
mi ridai la speranza grazie
invece di comprare una seconda gpu manderò donazione


Fri Oct 25, 2019 10:30 pm
Profile
One Eyed Hopeful

Joined: Mon Sep 16, 2019 6:47 am
Posts: 8
Reply with quote
DJ-RK wrote:
Ok, so I think I've figured out why (up until now) I haven't been seeing the same thing as everyone else. Up until today I've had 2 GPU's and SLI enabled. I just pulled out one of my cards (going to sell it. Sick of it sitting around not being used at all, since SLI is effectively dead), and it finally occurred to me how usually these types of issues are related to SLI setups (although it's usually the other way around: people with SLI have issues and single GPU's are fine) so I fired up the game, and low and behold I was presented with fire appearing in one eye only, whereas before it was perfectly fine.

So yeah, that's a HUGE step towards me fixing this stuff is that I'm able to see the same thing others are... or, y'know, you could all just go out and buy a 2nd GPU instead and save me the hassle! lol j/k.


I turned on SLI and that solved all the issues mentioned.. its just beautiful!
thank u DJ


Sat Oct 26, 2019 3:58 am
Profile
Cross Eyed!

Joined: Thu Sep 19, 2019 8:13 pm
Posts: 164
Reply with quote
Spent most of today working on this, focusing on sorting out the one-eyed and other remaining graphical issues. I'm happy to say that I've made some pretty good progress on that and mostly resolved these issues, however this game has been giving me a headache due to there being quite a few conflicts where certain shaders are used for multiple different effects, some requiring a fix and some not, and I don't have any way to separate or differentiate them, so my only solution is to be able to provide toggle keys for these.

Here are the conflicts:
-The dust in the background when you first enter the haunted manor (Pontius's intro stage) is broken by default. The fix for can be toggled on/off by pressing the . key, but doing so breaks the snow dust in Amadeus's intro level.
-The "swish" lines when swinging on Zoya's rope have far too much separation, but adjusting them causes all smoke/fog to become broken. You can disable the swish but that also will disable smoke and fog effects via the ; key.
-I've managed to fix the blocky clipping on shadows in certain areas (mainly on Zoya's stage), however in certain cutscenes they become more broken. I have a disable key for the fix on the ' key. (I don't think there's any need to use this, but it's there).

All in all, I'm glad to have made progress and the early game is in pretty good shape, but I'm getting pretty annoyed at how this game works and having to go back and forth on fixing things. Can't tell you how frustrating it is to find a fix for an issue, and replay an earlier level to find that now something else has been made broken by it and there not really be anything that can be done about it (again, other than setting up toggles, which I personally hate to do). Not to mention there are certain things (usually shadows) that insist on appearing broken when I see them, so I dump them to look into fixing them, and when I eventually alt+tab back into the game without even modifying them and now the shadow looks perfectly fine, that's just straight fuckery and there's not really anything I can do about it. They ARE fixed, apparently, but want to be broken sometimes too. Enough to drive me mad, I tell ya. Oh, there's also an aggressive occlusion culling that causes some of the distant geometry in the background of Zoya's stage to flicker/disappear. Doesn't appear to be anything I can do for that.

Anyways, enough ranting, and onto more testing. Here's the latest WIP. Please let me know if this solves these issues for you, or what issues you may come across. I haven't played beyond the 3 intro levels while fixing this today, so I'm not certain if there's not any other one-eye broken stuff later on yet, so I'd appreciate for people to test for me and let me know specifically where anything is that they come across. Thanks.

Download: http://www.mediafire.com/file/85ymywwfl ... _WIP_4.zip


Tue Oct 29, 2019 2:16 am
Profile
Two Eyed Hopeful
User avatar

Joined: Mon Sep 16, 2019 10:01 am
Posts: 52
Reply with quote
Thanks

Almost perfect, artifacts on the left eye
see the pictures
[url][URL=http://imgbox.com/WfH5WHr0]Image[/url][/url]

[url][URL=http://imgbox.com/0VF7dztd]Image[/url][/url]

download from dropmega to see original .jps
https://www.dropmega.com/b573730e5c5407c3


Tue Oct 29, 2019 4:17 am
Profile
Two Eyed Hopeful

Joined: Mon Sep 16, 2019 8:29 am
Posts: 76
Reply with quote
Thanks DJ-RK - fix is looking really good.

I, too, am getting artifacts from time to time - mostly in outdoor areas and (it seems) when the purple fog makes itself present. Will keep playing through the day - at this point, through the first three individual levels and almost done with the first "real" level.


You do not have the required permissions to view the files attached to this post.


Tue Oct 29, 2019 9:54 am
Profile
Cross Eyed!

Joined: Thu Sep 19, 2019 8:13 pm
Posts: 164
Reply with quote
Ok guys, so this:

maurizioclaudio21 wrote:
Thanks
Almost perfect, artifacts on the left eye
[url][URL=http://imgbox.com/WfH5WHr0]Image[/url][/url]


and this:

thebigdogma wrote:
Thanks DJ-RK - fix is looking really good.

I, too, am getting artifacts from time to time - mostly in outdoor areas and (it seems) when the purple fog makes itself present. Will keep playing through the day - at this point, through the first three individual levels and almost done with the first "real" level.

Image


are perfect examples of when I said this:

DJ-RK wrote:
Not to mention there are certain things (usually shadows) that insist on appearing broken when I see them, so I dump them to look into fixing them, and when I eventually alt+tab back into the game without even modifying them and now the shadow looks perfectly fine, that's just straight fuckery and there's not really anything I can do about it. They ARE fixed, apparently, but want to be broken sometimes too. Enough to drive me mad, I tell ya.



To prove it, here are some of my screenshots:

Image

Notice the tree on the far left is not broken like in Mauricio's pic

Image

And this one, as you can see the lighting on the building on the right is perfectly fine.


Ok, now here's the real kicker to demonstrate exactly what I'm talking about. See this next pic.

Image

Clearly broken shadows around the snowballs in the background around the middle of the screen.


And now see this.

Image

Taadaaaaaa. Fixed shadows. Amazing right? What did I do to fix them? I reloaded the checkpoint. :? (sometimes alt+tabbing is enough to do it, sometimes not). So guys, I'm sorry but I can't fix this kinda stuff. Well, I mean I can and already did, but I can't help it if the busted ass engine decides to just straight f*ck around. Believe me, I've tried and already lost quite a few hours on this crap alone.

Just to be clear here: If I sound like I'm annoyed it's because I am, but it's with this game and it's BS. I'm NOT annoyed with you guys reporting this issue. I just wanted to take this opportunity to clearly show this nonsense that this game is pulling, not attack you guys (if it came across that way).

Oh, and one thing I haven't mentioned before is the shadow that is created by the characters: Can't do nothing about those. Those are tied to the same shaders that fix every other shadow in the game, and there's no specific point to adjust character shadows. Those are correct 90% of the time because of the auto-convergence shader gets them to the right depth, but at certain zoom lengths they just won't be correct.

On another note, today there was an update and guess what? It broke a bunch of stuff that I fixed. Yay. Object outlines and the lighting clipping that I had literally just fixed last night, gone. Not a huge matter for me to update (already have done most of it just while gathering these pictures), but hopefully this won't be too frequent of a thing because I'm not going to update a fix every couple days because object outlines aren't perfect (while nearly everything else is).


Edit: Ok, so I actually downloaded and took a closer look at Mauricio's pictures and see those aren't just broken shadows, it looks like he's experiencing some of the blocky clipping there that is more related to the one-eye fix stuff I just implemented than the shadows issue. Think I might know why (I have to use specific hashes for certain textures that I stereoize, and I'm assuming those hashes are different on his machine), and I'll have to investigate to see if I can figure out why. Perhaps it's based on resolution. What resolution do you play at, Mauricio?


You do not have the required permissions to view the files attached to this post.


Tue Oct 29, 2019 11:25 am
Profile
Two Eyed Hopeful

Joined: Mon Sep 16, 2019 8:29 am
Posts: 76
Reply with quote
LOL - I understand what you are talking about now.

Thanks again DJ-RK - please don't stress about any of the engine shenanigans. I'll take WIP4 as-is - the fact that we can play this game in 90% perfect S3D is more than good enough for me!


Tue Oct 29, 2019 12:49 pm
Profile
Cross Eyed!

Joined: Thu Sep 19, 2019 8:13 pm
Posts: 164
Reply with quote
Appreciate you understanding and willing to accept it for what it is. To be fair, though, whatever you shown in the first pic seems to be more one-eyed fuckery, and that's the type of stuff that I DO need reported. What level is that (how far into the game)? If you could report whatever issues you find with level #, and if possible, checkpoint # as well that would be great. Need to see if I can get a 100% complete savegame so I can skip around as needed, since I'm trying to reserve actually playing this game with my coop partner.


Tue Oct 29, 2019 2:05 pm
Profile
One Eyed Hopeful

Joined: Wed Oct 23, 2019 2:45 pm
Posts: 2
Reply with quote
Amazing, that is just perfect, thanks a lot for this new version !


Tue Oct 29, 2019 2:34 pm
Profile
Two Eyed Hopeful

Joined: Mon Sep 16, 2019 8:29 am
Posts: 76
Reply with quote
DJ-RK wrote:
Appreciate you understanding and willing to accept it for what it is. To be fair, though, whatever you shown in the first pic seems to be more one-eyed fuckery, and that's the type of stuff that I DO need reported. What level is that (how far into the game)? If you could report whatever issues you find with level #, and if possible, checkpoint # as well that would be great. Need to see if I can get a 100% complete savegame so I can skip around as needed, since I'm trying to reserve actually playing this game with my coop partner.


That first pic is from the first full level of the game (Craghill Moors.)

As an FYI, I didn't start playing with WIP4 installed until after the patch was applied - so sounds like some of the issues I have experienced are related to that.


Tue Oct 29, 2019 3:02 pm
Profile
Two Eyed Hopeful

Joined: Mon Sep 16, 2019 8:29 am
Posts: 76
Reply with quote
Couldn't resist... a couple of shots (the night shots are from the "Moonlit Forest" level - first level in Act III) showing how truly spectacular the game looks.


You do not have the required permissions to view the files attached to this post.


Tue Oct 29, 2019 5:38 pm
Profile
Cross Eyed!

Joined: Thu Sep 19, 2019 8:13 pm
Posts: 164
Reply with quote
Excellent shots. This game is definitely a sight to behold.

Your third shot reminds me that I forgot to mention that the arrow shot trails are basically the same as the rope swing swish... and also if you use the mouse cursor to draw boxes for Amadeus. Why the Hell they share the same shader as smoke and fog? Beats me, but because devs decided to be lazy we have to suffer with the result. Probably the most jarring thing left since it happens during gameplay.


Tue Oct 29, 2019 8:16 pm
Profile
Two Eyed Hopeful
User avatar

Joined: Mon Sep 16, 2019 10:01 am
Posts: 52
Reply with quote
@DJ-RK
Edit: Ok, so I actually downloaded and took a closer look at Mauricio's pictures and see those aren't just broken shadows, it looks like he's experiencing some of the blocky clipping there that is more related to the one-eye fix stuff I just implemented than the shadows issue. Think I might know why (I have to use specific hashes for certain textures that I stereoize, and I'm assuming those hashes are different on his machine), and I'll have to investigate to see if I can figure out why. Perhaps it's based on resolution. What resolution do you play at, Mauricio?


Thanks for the reply
play at 1920 x 1080
I have a 24 "monitor


Tue Oct 29, 2019 11:46 pm
Profile
Cross Eyed!

Joined: Thu Sep 19, 2019 8:13 pm
Posts: 164
Reply with quote
Alright chaps, figured out why some of you are still experiencing some clipping/one eye issues. Different AA settings cause the textures that need to be adjusted to have differing hashes. I have been using the High - 2 x SSAA setting, so if you were using anything else then that would have caused some of my fixes to not apply. I will also fix the Low / No AA, and Medium - TAA settings, but I don't have time for that today. I haven't tested to see if resolution also plays a factor on top of that yet, though. Maurizio and BigDogma, if you could take a moment to try out the High - 2xSSAA setting and confirm if that sorts out some of your issues would be appreciated.


Thu Oct 31, 2019 11:52 am
Profile
Two Eyed Hopeful

Joined: Mon Sep 16, 2019 8:29 am
Posts: 76
Reply with quote
DJ-RK wrote:
Alright chaps, figured out why some of you are still experiencing some clipping/one eye issues. Different AA settings cause the textures that need to be adjusted to have differing hashes. I have been using the High - 2 x SSAA setting, so if you were using anything else then that would have caused some of my fixes to not apply. I will also fix the Low / No AA, and Medium - TAA settings, but I don't have time for that today. I haven't tested to see if resolution also plays a factor on top of that yet, though. Maurizio and BigDogma, if you could take a moment to try out the High - 2xSSAA setting and confirm if that sorts out some of your issues would be appreciated.


With AA set to high...


You do not have the required permissions to view the files attached to this post.


Thu Oct 31, 2019 2:25 pm
Profile
Cross Eyed!

Joined: Thu Sep 19, 2019 8:13 pm
Posts: 164
Reply with quote
I see some blocky shadows in that first pic (which is because of the update nullifying my blocky shadows fix, but I'll have that resolved in the next fix version), and the other 2 pics look good, so I take it this is your report that switching to high AA has been an improvement?


Thu Oct 31, 2019 2:36 pm
Profile
Two Eyed Hopeful

Joined: Mon Sep 16, 2019 8:29 am
Posts: 76
Reply with quote
DJ-RK wrote:
I see some blocky shadows in that first pic (which is because of the update nullifying my blocky shadows fix, but I'll have that resolved in the next fix version), and the other 2 pics look good, so I take it this is your report that switching to high AA has been an improvement?



I think so (?)... here are a couple with AA at the highest setting. These look to be an improvement to my eyes.


You do not have the required permissions to view the files attached to this post.


Thu Oct 31, 2019 3:05 pm
Profile
Cross Eyed!

Joined: Thu Sep 19, 2019 8:13 pm
Posts: 164
Reply with quote
Weekend's here everybody, and thanks to everyone's testing, feedback, and support I'm confident this is ready for it's full release. Latest version has the one-eye fix for the AA options: Off, TAA, and SSAAx2 (I could have done SSAAx3 and SSAAx4, but it actually took a fair bit of time for me to track down the correct hashes for each AA level, and realistically no one probably has the horsepower to run it, and it's hardly necessary vs SSAAx2 so I just decided not to bother).

I've changed around the hotkeys to the F-keys. Please also read the instructions, particularly about how the game reacts to having a high separation value (ie. you shouldn't).

I just spent a good while writing the blog post, so I don't really feel like resummarizing it all here, so please check out all the details here: http://helixmod.blogspot.com/2019/11/trine-4.html


Sat Nov 02, 2019 1:35 am
Profile
One Eyed Hopeful
User avatar

Joined: Fri Sep 27, 2019 11:23 pm
Posts: 5
Reply with quote
@DJ-RK, Thank You :-) I'm going to back up the whole game directory right now! Fantastic game.

_________________
Win 7 pro, IX Apex, 6700k, 2x1080t, 1x1060sc, 425.31, PG278QR


Sat Nov 02, 2019 2:29 am
Profile
Two Eyed Hopeful

Joined: Mon Sep 16, 2019 8:29 am
Posts: 76
Reply with quote
DJ-RK wrote:
Weekend's here everybody, and thanks to everyone's testing, feedback, and support I'm confident this is ready for it's full release. Latest version has the one-eye fix for the AA options: Off, TAA, and SSAAx2 (I could have done SSAAx3 and SSAAx4, but it actually took a fair bit of time for me to track down the correct hashes for each AA level, and realistically no one probably has the horsepower to run it, and it's hardly necessary vs SSAAx2 so I just decided not to bother).

I've changed around the hotkeys to the F-keys. Please also read the instructions, particularly about how the game reacts to having a high separation value (ie. you shouldn't).

I just spent a good while writing the blog post, so I don't really feel like resummarizing it all here, so please check out all the details here: http://helixmod.blogspot.com/2019/11/trine-4.html


Tremendous work DJ-RK - thanks so much!

Reducing separation was the key for me - makes a HUGE difference at 50% and you really don't feel like you've lost any depth.

Re-started the game so I could enjoy it in all of its S3D glory - I love this series and 4 is the best of the bunch.


Sat Nov 02, 2019 10:12 am
Profile
Two Eyed Hopeful

Joined: Mon Sep 16, 2019 8:29 am
Posts: 76
Reply with quote
Pure beauty! :D


You do not have the required permissions to view the files attached to this post.


Sat Nov 02, 2019 11:31 am
Profile
Two Eyed Hopeful
User avatar

Joined: Mon Sep 16, 2019 10:01 am
Posts: 52
Reply with quote
What driver you are using , I keep seeing some of the blocky clipping with left eye, I set AA options: Off
thanks

if I put convergence 16
and separation 22 is not bad
is it ok to set this way?


Sat Nov 02, 2019 11:46 am
Profile
Cross Eyed!

Joined: Thu Sep 19, 2019 8:13 pm
Posts: 164
Reply with quote
maurizioclaudio21 wrote:
What driver you are using , I keep seeing some of the blocky clipping with left eye, I set AA options: Off
thanks

if I put convergence 16
and separation 22 is not bad
is it ok to set this way?


I'm still using 425.31, but I doubt driver version has anything to do with it (still, I always suggest that first when someone is having issues on the newer drivers, since those are using unofficial hacks to get 3D drivers in, so wouldn't hurt to try rolling back).

Can you try using TAA or 2xSSAA to see if either of those solve your issue?


Sat Nov 02, 2019 2:18 pm
Profile
Two Eyed Hopeful
User avatar

Joined: Mon Sep 16, 2019 10:01 am
Posts: 52
Reply with quote
DJ-RK wrote:
maurizioclaudio21 wrote:
What driver you are using , I keep seeing some of the blocky clipping with left eye, I set AA options: Off
thanks

if I put convergence 16
and separation 22 is not bad
is it ok to set this way?


I'm still using 425.31, but I doubt driver version has anything to do with it (still, I always suggest that first when someone is having issues on the newer drivers, since those are using unofficial hacks to get 3D drivers in, so wouldn't hurt to try rolling back).

Can you try using TAA or 2xSSAA to see if either of those solve your issue?


I use drivers 417.01 I'm still playing
Shadow of the Tomb Raider The Path Home
I have read with superior drivers there are problems with 3D
I tried to set TAA or 2xSSAA
but nothing changes
Image
The only system that is found to decrease the problem is set up conv. 16 and sep.22
thanks DJ-RK


Sat Nov 02, 2019 11:33 pm
Profile
One Eyed Hopeful

Joined: Sat Sep 21, 2019 4:21 am
Posts: 7
Reply with quote
I'm glad to see that the 3Dfix is working. Good job, DJ-RK!
But for me the game is not starting any more after instlling the fix!? I see a black screen a few seconds, then it closes back to desktop. Anybody here who had the same problem and can help me to get it working?

Edit: I still see the green text with "Trine 4 3D - WIP 1" after deleting the fix with the uninstall.bat when I start the game with 3D Vision enabled. So there must be some file left from the early WIP-version but where? Checking the game files in Steam did not help.

Edit2: Fixed it by installing the latest driver with 3DFix Manager.
But the green text is still "Trine4 3D - WIP1" and I see also the pixelated shadows.


Last edited by Scarhead on Sun Nov 03, 2019 7:13 am, edited 2 times in total.



Sun Nov 03, 2019 4:42 am
Profile
Cross Eyed!

Joined: Mon Sep 16, 2019 4:52 am
Posts: 152
Reply with quote
Thanks DJ-RK!


Sun Nov 03, 2019 5:59 am
Profile
Cross Eyed!

Joined: Thu Sep 19, 2019 8:13 pm
Posts: 164
Reply with quote
Scarhead wrote:
I'm glad to see that the 3Dfix is working. Good job, DJ-RK!
But for me the game is not starting any more after instlling the fix!? I see a black screen a few seconds, then it closes back to desktop. Anybody here who had the same problem and can help me to get it working?

Edit: I still see the green text with "Trine 4 3D - WIP 1" after deleting the fix with the uninstall.bat when I start the game with 3D Vision enabled. So there must be some file left from the early WIP-version but where? Checking the game files in Steam did not help.

Edit2: Fixed it by installing the latest driver with 3DFix Manager.
But the green text is still "Trine4 3D - WIP1" and I see also the pixelated shadows.


Yeah, I simply missed updating the green text message, so thanks for reporting that. I've now changed it and reuploaded the fix to reflect it's the v1.0 release.

As for pixelated shadows, that's part one of the issues when you run too high of a separation value, as explained in the blog post. You really need to drop down to 25-50% separation in this game to eliminate some visual anomalies and put the world to proper scale (100% separation has things too long, IMO. Like the room on the title screen turns into a great hall at full separation, which I don't think it's supposed to be)... or don't and put up with them if having a super deep amount of depth is more to your preference.


Sun Nov 03, 2019 9:47 pm
Profile
Cross Eyed!

Joined: Thu Sep 19, 2019 8:13 pm
Posts: 164
Reply with quote
maurizioclaudio21 wrote:
DJ-RK wrote:
maurizioclaudio21 wrote:
What driver you are using , I keep seeing some of the blocky clipping with left eye, I set AA options: Off
thanks

if I put convergence 16
and separation 22 is not bad
is it ok to set this way?


I'm still using 425.31, but I doubt driver version has anything to do with it (still, I always suggest that first when someone is having issues on the newer drivers, since those are using unofficial hacks to get 3D drivers in, so wouldn't hurt to try rolling back).

Can you try using TAA or 2xSSAA to see if either of those solve your issue?


I use drivers 417.01 I'm still playing
Shadow of the Tomb Raider The Path Home
I have read with superior drivers there are problems with 3D
I tried to set TAA or 2xSSAA
but nothing changes
*snipped*
The only system that is found to decrease the problem is set up conv. 16 and sep.22
thanks DJ-RK


I'm running out of options for you, my friend, but there is still one last thing we can try.

Please download and use the d3dx.ini file I've attached. Load up the game to the title screen. Press numpad 0 to bring up the green 3DMigoto overlay, and then press the F8 key. The game should seem to freeze up for about 5-10 seconds, and then it will resume and you'll see some green text at the top saying "Frame Analysis Saved to...". Exit the game, and now in the game folder there will now be a new folder called "FrameAnalysis-####-##-##-######" (where the #'s are all a date stamp). Please zip up this folder and then upload it (somewhere not sketchy, I'm good with mediafire, mega, google drive, dropbox, etc) and provide me with a link. I'll try to use that file to determine which texture hashes your system is creating, because somehow they are not the same as on my system. Before doing all this, make sure to set your resolution and AA level to your preference, and be sure to reply with which resolution and AA level you are using so I can hopefully use that info to make sense of things.


You do not have the required permissions to view the files attached to this post.


Sun Nov 03, 2019 10:00 pm
Profile
Two Eyed Hopeful
User avatar

Joined: Mon Sep 16, 2019 10:01 am
Posts: 52
Reply with quote
@DJ-RK

Thanks

http://www.mediafire.com/file/95iox3ypt ... 2.rar/file

my setup option video
texture max quality
AA disable
1920x 1080
resolution 1.00


Sun Nov 03, 2019 11:51 pm
Profile
Cross Eyed!

Joined: Thu Sep 19, 2019 8:13 pm
Posts: 164
Reply with quote
Ok Maurizio, I think I finally got you covered. In fact, I think I now have everyone covered across all resolutions and AA settings! By looking at your log it dawned on me to take a different approach to what I was doing (for shaderhackers reference: I was using a fuzzy texture match to set all UAV buffers to mono, and then finding specific texture hashes for those that setting to mono would break. Problem was that the texture hashes would change depending on the selected resolution and AA level. Instead I was able to find a common set of hashes that appeared no matter which resolution/AA setting, and just setting those to mono seems to be enough, rather than using such broad strokes with the fuzzy match... which sounds kinda obvious to try, and I did before, just with the hashes all individually instead of grouping them all together and setting them all at the same time)

Anyways, try this new d3dx.ini file. In fact, if my other fellow tester friends in here could also try this and verify it's good for them, so I know it's safe to update the official release with it would be appreciated (although I'm already about 99.9% sure it should be ok for them, at least on the title screen. Just not 100% this covers everything elsewhere, but the few stages I loaded up all seemed fine).


You do not have the required permissions to view the files attached to this post.


Mon Nov 04, 2019 1:24 am
Profile
Two Eyed Hopeful
User avatar

Joined: Mon Sep 16, 2019 10:01 am
Posts: 52
Reply with quote
@DJ-RK

Thanks, now is perfect
Image
I play it with my daughter tonight
thank you so much


Mon Nov 04, 2019 7:52 am
Profile
Cross Eyed!

Joined: Thu Sep 19, 2019 8:13 pm
Posts: 164
Reply with quote
Excellent. Glad we were able to finally find a universal solution to the issue, and able to get you on-board with enjoying this fully. Hope you and your daughter have a blast playing it!


Mon Nov 04, 2019 10:44 am
Profile
One Eyed Hopeful

Joined: Sat Sep 21, 2019 4:21 am
Posts: 7
Reply with quote
DJ-RK wrote:
Scarhead wrote:
I'm glad to see that the 3Dfix is working. Good job, DJ-RK!
But for me the game is not starting any more after instlling the fix!? I see a black screen a few seconds, then it closes back to desktop. Anybody here who had the same problem and can help me to get it working?

Edit: I still see the green text with "Trine 4 3D - WIP 1" after deleting the fix with the uninstall.bat when I start the game with 3D Vision enabled. So there must be some file left from the early WIP-version but where? Checking the game files in Steam did not help.

Edit2: Fixed it by installing the latest driver with 3DFix Manager.
But the green text is still "Trine4 3D - WIP1" and I see also the pixelated shadows.


Yeah, I simply missed updating the green text message, so thanks for reporting that. I've now changed it and reuploaded the fix to reflect it's the v1.0 release.

As for pixelated shadows, that's part one of the issues when you run too high of a separation value, as explained in the blog post. You really need to drop down to 25-50% separation in this game to eliminate some visual anomalies and put the world to proper scale (100% separation has things too long, IMO. Like the room on the title screen turns into a great hall at full separation, which I don't think it's supposed to be)... or don't and put up with them if having a super deep amount of depth is more to your preference.


I tried all different combinations of seperation and convergence also the recommended 16/22 and I always had blocky shadows but WITH THE LATEST D3DX.INI posted from you they are all gone and now it looks fantastic!

GREAT! Once again THANK YOU VERY MUCH!


Mon Nov 04, 2019 12:22 pm
Profile
Cross Eyed!

Joined: Thu Sep 19, 2019 8:13 pm
Posts: 164
Reply with quote
Great, glad that sorted it out for you, and that's enough confirmation I need to post an update to the blog, since this discovery means that anyone who was not running at 1440P would be facing these issues. If you are downloading the d3dx.ini file I've provided you won't need to update since that's the only thing that will be changing. Same thing applies if you do play at 1440P (since those were fine in the previous release), unless you do plan on using 3 or 4 x SSAA, since this will now work for those.


Mon Nov 04, 2019 1:06 pm
Profile
Two Eyed Hopeful

Joined: Mon Sep 16, 2019 8:29 am
Posts: 76
Reply with quote
DJ-RK wrote:
Ok Maurizio, I think I finally got you covered. In fact, I think I now have everyone covered across all resolutions and AA settings! By looking at your log it dawned on me to take a different approach to what I was doing (for shaderhackers reference: I was using a fuzzy texture match to set all UAV buffers to mono, and then finding specific texture hashes for those that setting to mono would break. Problem was that the texture hashes would change depending on the selected resolution and AA level. Instead I was able to find a common set of hashes that appeared no matter which resolution/AA setting, and just setting those to mono seems to be enough, rather than using such broad strokes with the fuzzy match... which sounds kinda obvious to try, and I did before, just with the hashes all individually instead of grouping them all together and setting them all at the same time)

Anyways, try this new d3dx.ini file. In fact, if my other fellow tester friends in here could also try this and verify it's good for them, so I know it's safe to update the official release with it would be appreciated (although I'm already about 99.9% sure it should be ok for them, at least on the title screen. Just not 100% this covers everything elsewhere, but the few stages I loaded up all seemed fine).


Thanks DJ-RK - that did the trick! Took the fix to another level and fixed the few minor issues I was having.. also allows for a better experience at higher separation. Still, I think, a good idea to keep it around 50%, but I can't help wanting to crank it every once in awhile! :D


Mon Nov 04, 2019 1:55 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 81 posts ]  Go to page Previous  1, 2, 3  Next

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by STSoftware.