Page 1 of 1

"Rundll32.exe" error when trying to run in SBS

Posted: Tue May 17, 2011 5:13 pm
by Exposed
I did a fresh Windows 7 installation on a new Samsung 1TB I bought for my gaming HTPC. Installed all necessary updates and ATI 11.5a hotfix. However, I can't run games in side by side mode with IZ3D, either the game crashes with "*** has stopped working" or "Windows host process rundll32.exe has stopped working."

In the IZ3D control panel, I can see the static test image for all outputs except for AMD3D and side by side. I already know AMD3D has lots of issues, but I'm surprised side by side doesn't work, especially since it worked fine on my previous build and current laptop.

Here are diagnostic results:

System Information

Time of this report: Wed May 18 22:32:21 2011

iZ3D Driver Version: 1.12.5123
OS Extended Long String (Localized): Windows 7 Ultimate 64-bit (6.1, Build 7600) (7600.win7_gdr.110408-1633)
OS Version: 6.1.7600.2
System type: 64-bit
DirectX Version Long String (English): DirectX 11
DirectX Version: 10.0
Physical Memory: 4096(Mb)
Used PageFile: 1667(Mb)
Available PageFile: 6485(Mb)
Direct3D8 Debug Runtime Available: 0
Direct3D Debug Runtime Running: 0
Direct3D Debug Level: 0
Windows Directory: C:\Windows
BuildLab: 7600.win7_gdr.110408-1633
DxDiag Version: 6.01.7600.16385
Processor String (English): Intel(R) Core(TM) i5-2500 CPU @ 3.30GHz (4 CPUs), ~3.3GHz
System Manufacturer String (English): MSI
System Model String (English): MS-7680
BIOS String (English): BIOS Date: 03/15/11 09:15:50 Ver: 04.06.04
Physical Memory String (English): 4096MB RAM
DirectX Version String (English):
PageFile String (Localized): 1667MB used, 6485MB available
MachineName (English): LANBOXLITE
Languages String (English): English (Regional Setting: English)
PageFile String (English): 1667MB used, 6485MB available
Time String (English): 5/18/2011, 18:32:20

Display Information

Display adapter: 0
Device name: \\.\DISPLAY1
Description: ATI Radeon HD 5800 Series
Key device ID: Enum\PCI\VEN_1002&DEV_6898&SUBSYS_0B001002&REV_00
Key device key: \Registry\Machine\System\CurrentControlSet\Control\Video\{6F1B2ADC-A2E9-42C1-8799-D10819849CE0}\0000
Manufacturer: ATI Technologies Inc.(Mb)
Chip type: ATI display adapter (0x6898)(Mb)
DACType: Internal DAC(400MHz)(Mb)
DisplayMemory (English): 2797 MB
DisplayMode (English): 1920 x 1080 (32 bit) (60Hz)
Screen width: 1920
Screen height: 1080
Bits per pixel: 32
Refresh rate: 60
Monitor name: Generic PnP Monitor
Monitor maximum resolution:
Driver name: aticfx64.dll,aticfx64.dll,aticfx64.dll,aticfx32,aticfx32,aticfx32,atiumd64.dll,atidxx64.dll,atidxx6
Driver version: 8.17.0010.1077
Driver attributes: Final Retail
DriverLanguage (English): English
DriverDate (English): 5/12/2011 15:40:08
Adapter: 0
VendorId: 0x1002
DeviceId: 0x6898
Attached Monitor DeviceId: MONITOR\SAM06AC\{4d36e96e-e325-11ce-bfc1-08002be10318}\0001
Attached Monitor Model: SAM06AC
Monitor display area size: 102cm x 57cm (diag 46")
DS texture format D16: supported
DS texture format D16 LOCKABLE: unsupported
DS texture format D24S8: supported
DS texture format D24X8: supported
DS texture format ATI DF16: supported
DS texture format ATI DF24: supported
DS texture format NVidia INTZ: supported
DS texture format NVidia RAWZ: unsupported
Surface format ATI AQBS: supported

Re: "Rundll32.exe" error when trying to run in SBS

Posted: Tue May 17, 2011 6:26 pm
by cybereality
Try disabling the DirectX 10/11 mode. Also make sure to stop any type of anti-virus you may have. I know there are issues with Comodo in particular.

Re: "Rundll32.exe" error when trying to run in SBS

Posted: Wed May 18, 2011 12:47 pm
by Exposed
Tried your suggestions plus a whole lot more. I finally figured out SBS will always crash if text/font size is set to 150% (from Windows 7 display properties). When set to 125% or 100%, SBS works fine. It only took me over a day of exhausting driver/setting troubleshooting to figure that out lol.

Now to get AMD3D to work.

Re: "Rundll32.exe" error when trying to run in SBS

Posted: Wed May 18, 2011 8:59 pm
by cybereality
Exposed wrote: Now to get AMD3D to work.
Let me know how that goes. I have tried everything I could, and still can't get it to work.